1. The command "mv file1 file2" will accomplish: a. "file1" will be copied to "file2" b. "file1" will be moved to "file2" and both files will exist with the same contents c. "file1" will be moved to "file2" and "file1" will no longer exist d. "file1" and "file2" will be deleted 2. Besides the root file system, what other file system is required to boot a usable system ? a. /usr b. /var c. /opt d. /home e. none of the above 3. What command would you use to produce a list of what users are doing? a. id b. who c. last d. whodo 4. What does the command "cd ../frank" accomplish? a. changes working directory to /frank b. displays the contents of /frank c. changes working directory to the subdirectory "frank" d. changes working directory to one directory hierarchy up and then to the subdirectory "frank" 5. What command do you use to show the current run level? a. runlevel b. who -u c. who -r d. who -H 6. What command is utilized to install a patch? a. instpatch b. patchadd c. addpatch d. pkginst 7. Excluding diskettes, the only type of disk-based file system that can be created on a standard Solaris 8 operating system is UFS. a. true b. false 8. What option works with mount, fsck, useradd, usermod, groupmod, groupadd? a. -x b. -y c. -o d. -1 9. Which of the following commands use option -o? a. useradd b. usermod c. userdel d. groupadd e. groupmod f. groupdel 10. What utilities will display information for all active processes on the system? a. ps b. prstat c. prtconf d. sdtprocess e. dmesg 11. You issue the command "pkill dtmail". What is default signal that kill command sends to "dtmail"? a. SIGKILL b. SIGINT c. SIGHUP d. SIGTERM 12. Executables can be identified as such by: a. an asterisk following the name using the ls -F command b. a hyphen in the first column using the ls -l command c. the directory in which they reside d. a filename ending in .exe 13. What file can alter the use of the cancel command on the keyboard? a. /etc/system b. /etc/kbd c. /etc/default/system d. /etc/default/kbd 14. What command is used to limit damage after the system is forced down? a. repair b. reset c. sync d. fixall 15. What command is used to determine whether a package has been successfully installed? a. pkgchk -v b. pkginfo -p c. chkpkg -v d. pkginst -v 16. When the command "mkdir -p d1/d2/d3" is performed, which of the following statements is correct? a. It will create the following 3 directories: /d1 and /d1/d2 and /d1/d2/d3 b. It will create the following 3 directories: /d1 and /d2 and /d3 c. It will create the following 2 directories: /d1 and /d1/d2/d3 d. It will not work 17. What does "mt -f" require? a. You have to specify a tape device name b. You have to specify the type of tape device c. You have to specify the tape length d. Nothing 18. True or false: It is necessary to install all available patches to have a properly functioning system. a. True b. False 19. What command would you use if you wanted to send output to a file and the screen at the same time? a. split b. tee c. more d. iosplit 20. A multitasking system ______. a. supports more than one processor at a time b. supports more than one user at a time c. supports more than one network connection at a time d. supports more than one process at a time 21. To change the default umask for the C shell, modify the umask variable in the ______ file. a. /etc/default/login b. /etc/login c. /var/login d. /etc/profile 22. Which commands below will create a file, if the file does not already exist? a. more filename b. cat filename c. vi filename d. touch filename 23. Which of the following versions of OpenBooot are currently supported by Sun Microsystems? a. 1.x b. 2.x c. 3.x d. 4.x 24. Which command should be used after system interruption occurs to minimize the damage? a. sync b. fsck c. halt d. check e. unmount g. probe -scsi 25. What is an illegal character for use in the host name? a. letter b. number c. slash (/) d. underscore (_) 26. What is the absolute (1) and symbolic (2) mode used for the setgid permission? a. (1) 1000   (2) t b. (1) 2000   (2) s c. (1) 4000   (2) s d. (1) 8000   (2) t 27. The ______ acts as an intermediary between applications running on a computer and the hardware inside the computer. It controls physical and virtual memory, schedules processes, and starts and stops daemons. All commands interact with it. a. file system b. shell c. storage d. kernel 28. What are the contents of /etc/skel? a. template of shell scripts b. default login scripts c. kernel system files d. host's name information 29. What is the default Korn shell prompt when logged in as root? a. # b. $ c. % d. & 30. What permissions are needed to change to a directory and list its contents? a. r-- b. rw- c. r-x d. --x 31. What is standard default file permission? a. rw-r--r-- b. rwxr-xr-- c. rw---x--x d. rwxrwxrwx 32. What would the command "alias dir ls" accomplish in the C shell? a. nothing, the syntax is invalid for the C shell b. change the default behavior of the ls command c. allow you to enter "dir" instead of "ls" when you want to list directory contents d. nothing, the C shell does not support aliases 33. When using admintool to add a user, the information in the Account Security section is stored in what file? a. /etc/passwd b. /etc/shadow c. /etc/group d. /etc/hosts 34. When using admintool to add a user, what is a valid choice for the Password field? a. Leave blank b. Enter a password c. No password - setuid only d. Normal password 35. What is the command used to delete a package? a. pkgrm b. pkgremove c. pkgmv d. pkgdel 36. Which characters in vi in command mode can change the cursor to last line mode? a. ;, |, ? b. :, /, ? 37. How do you change a user's primary group? a. chgrp -u b. usermod -g c. useradd -g d. grpchg -u 38. Which command displays a listing of all files one screen at a time? a. ls -la | more b. ls -la: more c. ls -ls d. ls -la more 39. What does the -o option on the useradd command do? A. Duplicates the user B. Allows the UID to be duplicated C. Duplicates the home directory and password D. Overwrites the default settings 40. Which of the following commands shows the packages installed? A. pkginfo B. patchadd -p C. showrev -p D. patchinfo 41. What contains most of the information about a file system? A. boot block B. inode C. superblock D. Disk Label E. UFS 42. What is the usage fo an inode? (choose all that apply) A. It stores the file size B. It stores the file type C. It store the content of the file or directory D. It stores the directory or file name E. None of the above 43. Which function is not performed by the /etc/group file? A. Assign secondary groups for users B. Assign a name to primary groups C. Provide a special group for super user privileges 44. How do you list the contents of a directory including hidden files? A. ls -l B. ls -a C. ls -h D. ls -* E. ls * 45. Which of the following allow you to schedule jobs? A. at B. cron C. scheduler D. vi E. cronat 46. If neither the /etc/cron.d/cron.deny file or the /etc/cron.d/cron.allow files exists, who an use cron? A. Only root B. All users C. Users in the sysadmin group and root D. None of the above 47. Type the command to check and repair the file system: ___________ 48. You execute the command chmod 2555 filename What permissions will display for the file? A. -r-xr-sr-x B. -rw-rwsrw- C. -r-srw-rw- D. -rwxrwxrwx E. -r-xr-xr-t 49. Select the correct sequence of steps to restore the root filesystem from tape onto the disk device /dev/rdsk/c0t0d0s0. 1. newfs /dev/rdsk/c0t0d0s0 2. ufsrestore rvf /dev/rmt/0 3. mount /dev/dsk/c0t0d0s0 /restore 4. fsck /dev/rdsk/c0t0d0s0 5. cd /restore 6. installboot bootblk /dev/rdsk/c0t0d0s0 7. ok bbot cdrom -s A. 1.7.4.3.5.2.6 B. 7.3.1.5.2.4.6 C. 7.1.3.5.2.6.4 D. 7.4.1.3.5.2.6 50. What key-sequence moves the cursor one character to the right in vi? a. l b. u c. k d. h 51. You type the following command: #chown -R user1 /export/homw/user1 What statement is true? A. Only /export/home/user1 is owned by user1 B. All files and directories in /export/home/user1 are owned by user1 C. All file and directories in /export/home/user1 and owned by user1, including /export/home/user1 D. Only user1 is owned by user1 52. Choose the two valid commands for installing patch 107588-01 A. patchadd -R /export/root/client /var/spool/patch/107588-01 B. patchadd -s /Solaris/_8x86/var/spool/patch/107588-01 C. patchadd /var/spool/patch/107588-01 D. patchadd -d /var/spool/patch/107588-01 53. Which of the folling OpenBoot commands created a custom device alias of disk2 for /sbus/esp/sd@2.0? A. devalias disk2 /sbus/esp/sd@2.0 B. nvalias disk2/ sbus/esp/sd@2.0 C. alias disk2 /sbus/esp/sd@2.0 D. nvalias disk2 sd@2.0 54. A patchadd command will fail under what conditions? A. a package being patched is not installed or only partially installed B. a package was installed with a -d argument C. the patch requires another patch that is not installed D. the current versionor a higher version of the patch is already installed 55. What is the file type of a CDROM file? A. pipe B. symbolic C. character D. block 56. What does the "t" mean in -rwx-----t? A. readable B. searchable C. setgid D. setuid E. sticky bit 57. Which of the following are false regarding the file /etc/mnttab? A. It records the devices that are currently mounted B. The file permission is 600 C. It describes defaults for each file system D. There is an additional entry of /vol if vold is enabled 58. What is the difference between at and cron? A. crontab jobs are scheduled to run once, at jobs are scheduled to run many times B. crontab is the scheduler, at executes the commands C. at is the scheduler, crontab executes the commands D. crontab jobs are scheduled to run mang times, at jobs are scheduled to run once 59. You can change your system run level with? A. reboot B. halt C. init D. who -r E. None of the above 60. Which key-sequence will quit vi without saving changes? a. :q! b. :q c. :ZZ d. ctrl-d